Data Center (VDX)

 VDX6740 EVPN VXLAN incorrect mac-ip

stasonuu's profile image
stasonuu posted 09-02-2021 15:15

Hello! I have a problem with advertise mac-ip route type via EVPN BGP. Usually mac-ip field has 2 parts: VNI + mac address, but VDX6740 advertise only mac address.

 

show bgp evpn neighbors 10.32.0.6 advertised-routes detail type mac

There are 2 routes advertised to neighbor 10.32.0.6
Status A:AGGREGATE B:BEST b:NOT-INSTALLED-BEST E:EBGP I:IBGP L:LOCAL
1 Prefix: MAC:[0][4c5e.0c66.e450], Status: BL, Age: 5h11m6s
NEXT_HOP: 10.32.0.21, Learned from Peer: Local Router
LOCAL_PREF: none, MED: 0, ORIGIN: incomplete, Weight: 0
AS_PATH: 65011
Extended Community: ExtCom:03:0c:00:00:00:00:00:08 RT 65011:271435492 RT 65011:3000036
Extended Community: ExtCom: Tunnel Encapsulation (Type Vxlan)
Adj_RIB_out count: 1, Admin distance 0
L2_vni: 3000036
ESI : 00.000000000000000000
RD: 10.32.0.20:32804

Attention to this:  Prefix: MAC:[0][4c5e.0c66.e450]

 

But when I running command show bgp evpn l2route type mac detail I see that VDX has both attributes VNI and mac address:

12      Prefix: MAC:[3000036][4c5e.0c66.e450],  Status: BL,  Age: 5h15m5s
NEXT_HOP: 0.0.0.0, Learned from Peer: Local Router
LOCAL_PREF: 100, MED: 0, ORIGIN: incomplete, Weight: 0
AS_PATH:
Extended Community: ExtCom:03:0c:00:00:00:00:00:08
Extended Community: ExtCom: Tunnel Encapsulation (Type Vxlan)
L2_vni: 3000036
ESI : 00.000000000000000000
RD: 10.32.0.20:1

How can I change this behavior and advertise both attributes?

 

Current configuration:

show version

Network Operating System Software
Network Operating System Version: 7.4.1
Copyright (c) 2017-2018 Extreme Networks, Inc.
Firmware name: 7.4.1
Build Time: 15:47:36 May 26, 2020
Install Time: 13:56:03 Aug 31, 2021
Kernel: 2.6.34.6

BootProm: 1.0.1
Control Processor: e500mc with 4096 MB of memory

Slot Name Primary/Secondary Versions Status
---------------------------------------------------------------------------
SW/0 NOS 7.4.1 ACTIVE*
7.4.1
SW/1 NOS 7.4.1 STANDBY
7.4.1




show running-config rbridge-id 1 router bgp
rbridge-id 1
router bgp
local-as 65011
capability as4-enable
fast-external-fallover
neighbor overlay-cvx peer-group
neighbor overlay-cvx remote-as 65002
neighbor overlay-cvx update-source loopback 1
neighbor overlay-cvx ebgp-multihop 32
neighbor spine-group peer-group
neighbor spine-group remote-as 65001
neighbor spine-group description connected to 4 spine-groups
neighbor spine-group capability as4 enable
neighbor 10.32.0.6 peer-group overlay-cvx
neighbor 10.32.32.54 peer-group spine-group
address-family ipv4 unicast

network 10.32.0.19/32
network 10.32.0.21/32
maximum-paths 8
graceful-restart
!
address-family ipv6 unicast

!
address-family l2vpn evpn
graceful-restart
neighbor overlay-cvx activate
neighbor overlay-cvx allowas-in 1
neighbor overlay-cvx next-hop-unchanged
neighbor overlay-cvx send-community both
!
!
!



show running-config overlay-gateway 833-2
overlay-gateway 833-2
type layer2-extension
ip interface Loopback 2
attach rbridge-id add 1-2
map vlan 36 vni 3000036
activate
!



show running-config rbridge-id 1 evpn-instance vxlan-36
rbridge-id 1
evpn-instance vxlan-36
route-target both auto ignore-as
rd auto
vni add 3000036
!
!

 

stasonuu's profile image
stasonuu

Help me please :disappointed_relieved:

Sam Pirok's profile image
Sam Pirok

Hi , I’m sorry for the long wait here. I haven’t been able to find any answers for you, would you be able to open a support case for this issue so we can get you in touch with an engineer to work on this with you? It would also help if we could get a packet capture showing some of the BGP advertisement packets as well; if you could attach that to your case, that would be appreciated. 

stasonuu's profile image
stasonuu

  Hi! I’am so sorry, but I don’t have support contract for our switches. And I can't open the case. We have not trivial objective - integration Arista fabric with Extreme VDX fabric.
I think that the first part of problem - we can't set route-target on evpn instance and the secand part problem - absense VNI in Segment tag ID in Route Type-2. Like this:


If engineers of Extreme Networks can help me I will so happy.