ExtremeWireless (Aerohive)

 AP130 firmware upgrade fails

helpdesk's profile image
helpdesk posted 02-24-2021 12:32

Unfortunately i have to make a new topic because i cannot reply on the old excisting topics anymore.

Im having this issue that our AP130 cannot be upgraded from the Hivemanager, Our current Firmware version is: 6.5r9a. The error message we get is: unable to save the image to the flash memory.

I already tried to reboot the devices but that doesn't help.

How can i solve this?

 

Christoph S.'s profile image
Christoph S.

Hello,

 

Try upgrading it manually by following these instructions:

https://extremeportal.force.com/ExtrArticleDetail?an=000078576

 

Thank you,

Sam Pirok's profile image
Sam Pirok

You should be able to manage the device in XIQ while on the firmware version 6.5r9a, the minimum is 6.5r3 for XIQ. I’d recommend checking your firewall to make sure you have the necessary ports allowing outbound traffic (UDP 12222, TCP 22, TCP 443, UDP123, HTTP80). If all of your firewall ports check out, I’d recommend enabling CAPWAP debugs on the AP, trying to update the AP to replicate the failure, and then pulling tech data from the AP so we can review those debug logs for you. 

 

This guide reviews how to enable CAPWAP debugs:https://extremeportal.force.com/ExtrArticleDetail?an=000057308&q=Capwap%20debug

This guide reviews how to get tech data:https://extremeportal.force.com/ExtrArticleDetail?an=000080320&q=Tech%20data

 

If you want to send the tech data to me at community@extremenetworks.com, I would be happy to take a look for you. 

helpdesk's profile image
helpdesk

thank you, i will try if it works and i'll let you know asap.

helpdesk's profile image
helpdesk

Hi Christoph, 
Unfortunately I don't have a lot of options when I log in directly on the AP.

 

Christoph S.'s profile image
Christoph S.

Hello,

 

Only use this interface to upgrade the HiveOS software manually per instructions, and if successful, you should be able to continue doing everything else from XIQ. 

 

Or proceed with Sams troubleshooting options. 

 

Thank you,

 

Chris

Ash Finch's profile image
Ash Finch

Just looking at the screenshot in the initial post and correct me if I’m wrong but the screenshot looks to be a On-Premise HiveManager? Is it just the one AP or several?

If just the one, it might be a one off and I’d go for the manual upgrade like Chris & Sam have mentioned.

If more than one, I’d say there’s an underlying problem that may cause you to have issues with upgrading in the future, since you should be able to update between those two firmware versions. Have a feeling I saw similar before where the APs couldn’t resolve the DNS of the HiveManager anymore, therefore couldn’t get the download to work. Also as it’s on-prem (I think) give the HM a reboot just in case as some oddities can occur over time.

helpdesk's profile image
helpdesk

Hi thank you for all the response and sorry for my late response, it has been a crazy week.

We work with the on-Premise Aerohive Applicance, we have about 44 Ap130's which are all out of date. Doing them one by one is not desirable. Next week i will check if our Appliance has the lastest version and wil also check some other suggestions you guys made. I’ll be back with the results :)