ExtremeWireless (Aerohive)

 Second Hand AP122s

Jump to Best Answer
BlL7zxoT's profile image
BlL7zxoT posted 01-17-2021 19:08

Hello Folks,

I’ve picked up a couple second hand AP122s and I was able to reset/re-configure one of them with the serial connection and CLI. But it seems the previous owner of the second one didn’t do any kind of “factory reset” on it before disposal and I can’t seem to reset it. It just boots up and comes to a login prompt with what I assume is the hostname of the device. They must have disabled the reset button in the config because I’ve tried holding that button in for well over 5 seconds (up to 30) and it always just boots to this same prompt and no username/password combination will work.

I can; however, get into the bootloader so it seems I should be able to load a new image via TFTP (https://extremeportal.force.com/ExtrArticleDetail?an=000056869) but I just need a firmware image. The current version on the AP I have been able to configure is HiveOS 7.0r4 build-145241. I’m not sure about this other one, nothing in the boot process seems to report the version number. It looks like 10.0r9b is the latest version for the AP122; can I go straight to that from 7.0r4 or will I need to go up incrementally? Is there a way to just copy the firmware image from the one working AP to the other one?

Any help is appreciated. Thanks!

Sam Pirok's profile image
Sam Pirok

The default credentials for an AP will always use “admin” as the username, and the password will either be “aerohive” or “Aerohive1”, just wanted to mention those in case you hadn’t tried them yet after a reset. You can go from 7.0r4 to 10.0r9b directly, but you won’t be able to copy firmware from one AP to another. That said, I’ve emailed you directly with instructions on how to get the firmware file you need. 

BlL7zxoT's profile image

Thanks Sam. Yeah, I’ve tried every username/password known to man, nothing works. I was able to load the new firmware, but stupid me, I assumed it would completely overwrite everything (including the current config). Turns out it didn’t so I still had the issue of not actually being able to log in and do anything on the AP.

Luckily, formatting the flash did wipe out the existing config so upon the next boot, everything was back at the out-of-the-box defaults. Now I’m in business.

Thanks again.

zlinuxboy's profile image

may i ask how to format the flash under bootloader?

Sam Pirok's profile image
Sam Pirok

Hi , this guide reviews how to TFTP flash a device via the bootloader: https://extremeportal.force.com/ExtrArticleDetail?an=000056869&q=TFTP%20flash

Something to note, for step 4 in that guide, you will need to schedule a call with an Extreme technician so they can enter the bootloader password for you.

If you are unable to open a support case, please let me know and you and I can set up a call so I can enter the password for you instead. Just to set expectations here, I can help you enter the password but I am not a technician and cannot help you with the other steps in that guide. If you need further assistance than just the bootloader password, you’ll need to purchase support to file a support request with our engineers.