ExtremeCloud IQ

 Cannot update AP120 on extreme cloud IQ

Jump to Best Answer
boombasstic's profile image
boombasstic posted 06-29-2021 15:15



i’m having the same issue that on this post



I just cannot update to the latest image my AP120.


I have about 80 AP 120 i would like to connect to cloud IQ, but i have an error message qwhen trying to update to the latest image.


I read on the post above that there is a way to make it work.

If someone could help, i’d appreciate it.



boombasstic's profile image

som additional, my AP120 are running image 6.2r1c

i tried uploading with TFTP 6.5r3 and 6.5r4

update never go through, and then the AP is unresponsive. i think i bricked 5 or 6 of them trying different things :sweat_smile:


i probably need image files betweek 2r1c and the 6.5 im trying to update to, but they are not on the download page.

Sam Pirok's profile image
Sam Pirok

Hi there, sorry about the delay here. I’ve emailed you directly with instructions on how to find the firmware versions you’ll need. Please let me know if I can help with anything else!

boombasstic's profile image

i did not try yet to update it with the firmware that you sent me, because i had it already, and everytime i tried to update the AP it bricked them.

Wouldnt i need an other firmware to update from my “old” 6.2r1c version to the 6.5r3a?

boombasstic's profile image

so i tried with 6.5r3a with GUI and it worked.

Thanks Sam Pirok.

Sam Pirok's profile image
Sam Pirok

So glad to hear you were able to get the AP updated!

Just to answer your question in case someone else finds this thread later with the same question, for IQE devices on firmware versions 6.2r1 or newer, there is no stepwise upgrade needed, you can jump to any newer version directly. If devices are on firmware older than 6.1r6, we need to go to 6.1r6 first, then 6.2r1 directly after that. That is the only required stepwise upgrade for most IQE models. 

We also need IQE devices to be using 6.5r3 or later to use them with ExtremCloud IQ. 


Hope that helps!

boombasstic's profile image

So, i could update few AP120, but some other who are running the same firmware 6.2r1c cannot be updated.


with the GUI i get the following message “The HiveOS image is incorrect. Make sure that the image you are attempting to load is appropriate for the HiveAP platform and the difference with the image saved in HiveAP.”


if i update with the CLI, it just bricks the AP:

AH-6a9780#save image  tftp://
Do you really want to update image?(Y/N)Y
mode set to octet
Connected to (, port 69
getting from [octet]
Received bytes: 20114 KB
Received 20596848 bytes in 26.6 seconds [6193003 bit/s]
Image /tmp/aeros.img digital signature check: OK!
Programming bootloader ...
Erasing blocks: 2/4 (50%)


it hangs at Erasing blocks, and renders the AP useless.




Sam Pirok's profile image
Sam Pirok

Are these all AP 120’s? If you’re using different models, we’d need to use different firmware files. If they are all AP 120’s, I’d recommend resetting them to factory defaults and then trying again. If that doesn’t help, you may need to RMA these APs. 

BillyJZeramin's profile image

I too have two AP 120’s stuck on 5.1r5 and CloudIQ cannot update them. I’d really appreciate the firmware files to upgrade manually too as I can’t find them anywhere. Trying here first rather than starting a new thread. Thanks!

Sam Pirok's profile image
Sam Pirok

Hi , thanks for reaching out. I’ve emailed you directly with instructions on how to get the files you need, and a guide that reviews how to update the AP’s firmware via the Web UI. Please let me know if I can help with anything else!